Unexpected Error During Account Registration
Incident Report for MTG Arena
Resolved
We are seeing no further errors when attempting to register a new account, so we are marking this issue as resolved.
Posted 3 months ago. Dec 11, 2018 - 01:16 UTC
Monitoring
The issue with account registration appears to be resolved, however we are continuing to monitor the situation.
Posted 3 months ago. Dec 11, 2018 - 00:41 UTC
Investigating
We are currently investigating reports of players receiving an "Unexpected Error. Please try again." message when attempting to register a new account.
Posted 3 months ago. Dec 11, 2018 - 00:22 UTC
This incident affected: Logins.