In-Game Code Redemption
Incident Report for MTG Arena
Resolved
In-game code redemption appears to have stabilized, so we are marking this issue as resolved. For more information regarding our current promotions, please refer to the Magic: The Gathering Arena Promotions page: https://magic.wizards.com/en/promotions
Posted 6 days ago. Dec 07, 2018 - 05:34 UTC
Monitoring
We are monitoring continued reports of issues with in-game code redemption, specifically for the Game Awards Esports Starter Kit. If you receive a Code Redemption Error, please wait a few minutes and try again.

For more information on the code, including its contents and how long you have to redeem, please refer to our Promotions Page: https://magic.wizards.com/en/promotions
Posted 6 days ago. Dec 07, 2018 - 04:21 UTC
This incident affected: Game and Store.