Store experiencing degraded service
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted 14 days ago. Nov 28, 2018 - 19:43 UTC
Investigating
We are currently investigating this issue.
Posted 14 days ago. Nov 28, 2018 - 17:20 UTC
This incident affected: Store.