MAY 10 - PayPal
Incident Report for MTG Arena
Resolved
The issue is now resolved. Thank you for your patience.
Posted 5 months ago. May 10, 2019 - 18:18 UTC
Investigating
We're currently investigating reports of players being unable to complete purchases via PayPal. We'll update you with more information when it becomes available.
Posted 5 months ago. May 10, 2019 - 16:33 UTC
This incident affected: Store.