Unscheduled Store Downtime
Incident Report for MTG Arena
Resolved
The issue has been resolved, and players are now able to make purchases via the in-game store. Any player who made a purchase during the impacted time should now see the items and/or gems on their account.
Posted 2 months ago. Oct 13, 2018 - 00:47 UTC
Investigating
We have currently disabled the in-game store while we investigate issues with players being unable to complete their purchases. Players will be unable to purchase gems, bundles or packs at this time.
Posted 2 months ago. Oct 12, 2018 - 23:14 UTC
This incident affected: Store.