MTG Arena Status Page
All Systems Operational
Platform Operational
Windows ? Operational
macOS ? Operational
Android ? Operational
iOS Operational
Game ? Operational
Logins ? Operational
Matches ? Operational
Social ? Operational
Store ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Mar 28, 2024

No incidents reported today.

Mar 27, 2024

No incidents reported.

Mar 26, 2024
Completed - The scheduled maintenance has been completed.
Mar 26, 18:30 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 26, 15:30 UTC
Scheduled - @MTG_Arena maintenance will occur to deploy the 2024.35.30 game update.

πŸ“₯ Small download required.
πŸ”„ Restart required.
⏲️ ~3 hour estimated deployment.
πŸ“ Patch notes soon after.

Mar 25, 20:26 UTC
Mar 25, 2024

No incidents reported.

Mar 24, 2024

No incidents reported.

Mar 23, 2024

No incidents reported.

Mar 22, 2024

No incidents reported.

Mar 21, 2024

No incidents reported.

Mar 20, 2024

No incidents reported.

Mar 19, 2024

No incidents reported.

Mar 18, 2024

No incidents reported.

Mar 17, 2024

No incidents reported.

Mar 16, 2024

No incidents reported.

Mar 15, 2024
Resolved - This issue is now resolved.
Mar 15, 21:57 UTC
Investigating - We are aware of a live issue affecting @MTG_Arena. Players may experience disconnections and/or interruptions with play at this time. We will update you with more information when it becomes available.
Mar 15, 19:47 UTC
Mar 14, 2024
Completed - The scheduled maintenance has been completed.
Mar 14, 18:30 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Mar 14, 15:30 UTC
Scheduled - @MTG_Arena maintenance will occur to deploy the previously postponed 2024.35.10 game update, containing various bug fixes related to the Alchemy: Karlov Manor game update.

πŸ“₯ Small download required.
πŸ”„ Restart required.
⏲️ ~3 hour estimated deployment.
πŸ“ Patch notes soon after.

Mar 13, 23:40 UTC