MTG Arena Status Page
All Systems Operational
Platform Operational
Windows ? Operational
macOS ? Operational
Android ? Operational
iOS Operational
Game ? Operational
Logins ? Operational
Matches ? Operational
Social ? Operational
Store ? Operational
Operational
Degraded Performance
Partial Outage
Major Outage
Maintenance
Past Incidents
Apr 16, 2024
Completed - The scheduled maintenance has been completed.
Apr 16, 18:00 UTC
In progress - Scheduled maintenance is currently in progress. We will provide updates as necessary.
Apr 16, 15:00 UTC
Scheduled - @MTG_Arena maintenance will occur to deploy the 2024.36.0 game update, containing the Outlaws of Thunder Junction card set.

๐Ÿ“ฅ Large download required.
๐Ÿ”„ Restart required.
โฒ๏ธ ~3 hour estimated deployment.
๐Ÿ“ Patch notes soon after.

Apr 15, 23:46 UTC
Apr 15, 2024

No incidents reported.

Apr 14, 2024

No incidents reported.

Apr 13, 2024

No incidents reported.

Apr 12, 2024

No incidents reported.

Apr 11, 2024

No incidents reported.

Apr 10, 2024

No incidents reported.

Apr 9, 2024

No incidents reported.

Apr 8, 2024

No incidents reported.

Apr 7, 2024

No incidents reported.

Apr 6, 2024

No incidents reported.

Apr 5, 2024

No incidents reported.

Apr 4, 2024

No incidents reported.

Apr 3, 2024

No incidents reported.

Apr 2, 2024

No incidents reported.