Unable to Update to Latest Version
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted about 2 months ago. Oct 18, 2018 - 17:54 UTC
Monitoring
A fix has been implemented and we are monitoring the results.
Posted about 2 months ago. Oct 18, 2018 - 17:33 UTC
Investigating
We are investigating reports of players being unable to automatically update their client to the latest version. We will update you with more information when it is available. In the meantime, you can download the latest version manually at: mtgarena.com
Posted about 2 months ago. Oct 18, 2018 - 16:27 UTC
This incident affected: Game.