Forums - "404 Not Found"
Incident Report for MTG Arena
Resolved
The issue has been resolved and the forums are now available. Thank you for your patience.
Posted 8 months ago. Nov 15, 2018 - 21:26 UTC
Investigating
We are investigating reports of players receiving a "404 Not Found" error message when attempting to access the Magic: The Gathering Arena forums.
Posted 8 months ago. Nov 15, 2018 - 20:52 UTC
This incident affected: Forums.