Emergency Game Downtime - October 2, 2018
Incident Report for MTG Arena
Resolved
This maintenance and incident are resolved. The game is back up, thanks for your patience.
Posted 10 months ago. Oct 02, 2018 - 21:40 UTC
Monitoring
We have resolved the issues we were seeing and are monitoring successes before completing the remaining maintenance tasks.
Posted 10 months ago. Oct 02, 2018 - 21:11 UTC
Identified
During Scheduled Maintenance we experienced some issues that required us to take the game down.
Posted 10 months ago. Oct 02, 2018 - 20:39 UTC
This incident affected: Game, Logins, Matches, and Store.