Emergency Maintenance - October 1, 2018
Incident Report for MTG Arena
Resolved
This maintenance is complete.
Posted 2 months ago. Oct 02, 2018 - 18:06 UTC
Investigating
Emergency Maintenance is needed October 1, 2018 from 10:15 UTC - October 2, 2018 00:45 UTC. The store will be down during this time, including gem, bundle, and pack purchases, and redeeming codes.
Posted 2 months ago. Oct 02, 2018 - 18:05 UTC
This incident affected: Store.