Impacted Performance
Incident Report for MTG Arena
Resolved
This issue has been resolved. Thank you for your patience.
Posted about 1 month ago. Dec 11, 2018 - 23:34 UTC
Investigating
We are currently experiencing impacted performance for some of Magic: The Gathering Arena's services. A small portion of our players may experience performance or connection issues at this time.

We apologize for any inconvenience.
Posted about 1 month ago. Dec 11, 2018 - 20:26 UTC
This incident affected: Game and Matches.