Account Errors
Incident Report for MTG Arena
Resolved
This incident is resolved. Please visit support.wizards.com if you believe you are still experiencing issues.
Posted 3 months ago. Sep 28, 2018 - 20:44 UTC
Investigating
We are investigating reports of users experiencing a "Playfab Unknown Error" on login and migration.
Posted 3 months ago. Sep 28, 2018 - 20:28 UTC
This incident affected: Logins.