FEB 19 - Championship Trophy Pet
Incident Report for MTG Arena
Resolved
Players who previously redeemed their #FindYourChampion code should now have the Championship Trophy in their collection. If you continue to experience issues, please contact support.
Posted Feb 21, 2020 - 00:09 UTC
Update
Players can now redeem the code and receive all of their rewards. For players who previously redeemed the code and do not have the pet in their collection, we'll be deploying a separate fix as soon as possible. More Details: https://forums.mtgarena.com/forums/threads/63514
Posted Feb 20, 2020 - 20:14 UTC
Identified
We're aware of an issue affecting the Championship Trophy pet disappearing from player's collections. We have identified the issue and are working on a fix. We will update you with more information once it becomes available.
Posted Feb 20, 2020 - 01:44 UTC
This incident affected: Game and Store.