Password Reset
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted 4 months ago. Apr 25, 2019 - 06:03 UTC
Investigating
We are currently investigating an issue with our reset password site. Additionally, players may be unable to log into the forums, customer service site, and/or bug report site at this time.
Posted 4 months ago. Apr 25, 2019 - 00:36 UTC
This incident affected: Logins and Forums.