UPDATE: Unscheduled Store Downtime
Incident Report for MTG Arena
Resolved
We have seen no further issues with in-game purchases, and are marking this incident as resolved.
Posted 2 months ago. Oct 13, 2018 - 02:43 UTC
Monitoring
The subsequent issue has been resolved and the in-game store is now enabled, however we are continuing to monitor the situation.
Posted 2 months ago. Oct 13, 2018 - 01:18 UTC
Investigating
Update to Oct 12, 23:14 UTC Incident: We are continuing to see issues with purchases so we have once again disabled the in-game store. Players will be unable to purchase gems, bundles or packs during this time. We apologize for any inconvenience.
Posted 2 months ago. Oct 13, 2018 - 01:07 UTC
This incident affected: Store.