Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 02, 2025 - 15:30 UTC
Scheduled
@MTG_Arena maintenance will occur to deploy the 2025.51.20 game update, containing Through the Omenpaths preorder bundles and other important updates.
⛔Matchmaking Downtime: As a part of this maintenance, matchmaking will be disabled for up to 2.5 hours.
📥 Small download required. 🔄 Restart required. ⌨ Players may be forcibly logged out/required to log back in. ⏲️ ~3 hour estimated deployment. 📝 Patch notes soon after.
Posted Sep 02, 2025 - 08:06 UTC
This scheduled maintenance affected: Platform (Windows, macOS, Android, iOS) and Game, Logins, Matches, Social, Store.