NOV 11 - Investigating
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Nov 11, 2021 - 22:51 UTC
Investigating
We are investigating reports of issues with match completion and players timing out mid-match. Matchmaking is currently disabled. Updates will be provided when necessary.
Posted Nov 11, 2021 - 18:10 UTC
This incident affected: Game, Logins, Matches, Social, and Store.