AUG 24 - Connection Issues
Incident Report for MTG Arena
Resolved
We've identified the issue and have taken steps to improve connection issues and client responsiveness on @MTG_Arena. We're considering this issue resolved, though we'll continue to monitor the situation. Thank you!
Posted Aug 25, 2021 - 04:12 UTC
Investigating
We are investigating reports of connection and latency-related issues on @MTG_Arena. We will update you with more information as soon as possible.
Posted Aug 25, 2021 - 02:20 UTC
This incident affected: Game, Logins, Matches, Social, and Store.