Google Play Outage
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Mar 12, 2022 - 00:59 UTC
Investigating
We are aware of a potential outage preventing players from making purchases on @MTG_Arena through the Google Play store. We'll update you with more information when it becomes available.
Posted Mar 11, 2022 - 21:54 UTC
This incident affected: Platform (Android) and Store.