APR 25 - In-Game Store/Code Redemption
Incident Report for MTG Arena
Resolved
We have deployed a hotfix to address the issues with code redemption. Restarting your client and downloading the latest update is strongly recommended.

Codes have been re-enabled at this time. More info: https://forums.mtgarena.com/forums/threads/55146
Posted 4 months ago. Apr 26, 2019 - 00:33 UTC
Identified
We have identified the issue, and we are working on a fix. Code redemption is still disabled at this time; you will receive a "Code Redeem Failure" message when attempting to redeem one of the impacted codes.

For any other store related issues, please restart your client. If this does not solve the issue, please contact support: https://mtgarena-support.wizards.com/hc/en-us

We will update you with more information when it becomes available.
Posted 4 months ago. Apr 25, 2019 - 20:53 UTC
Update
We are temporarily disabling code redemption while we work to resolve these issues. You will now receive a "Code Redeem Failure" error when attempting to redeem one of the impacted codes.

If you successfully redeemed a code and did not receive your product, we are working on getting those items automatically credited to your account. You do not need to contact customer support at this time.

For any other store related issues, please restart your client. If this does not solve the issue, please contact support: https://mtgarena-support.wizards.com/hc/en-us
Posted 4 months ago. Apr 25, 2019 - 18:57 UTC
Investigating
We are currently investigating issues with players receiving their in-game purchases and code redemption.

If you successfully complete an in-game purchase and do not see the items/gems in your inventory, please restart your client. If this does not resolve the issue, please contact customer support: https://mtgarena-support.wizards.com/hc/en-us
Posted 4 months ago. Apr 25, 2019 - 18:28 UTC
This incident affected: Store.