SEP 8 - Mobile Gameplay Unresponsive
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Sep 09, 2022 - 21:18 UTC
Monitoring
A hotfix for this issue is now available, and a client update is required for all @MTG_Arena players. Please Note: It may take some time for the update for mobile versions to appear in their respective app stores.
Posted Sep 09, 2022 - 19:35 UTC
Investigating
We're aware of an issue affecting game play on mobile devices, where activating certain card abilities can cause MTG Arena to become unresponsive. We are currently working on a fix, and will update with more information when available. This does not affect game play on PC (Windows, macOS).
Posted Sep 08, 2022 - 21:34 UTC
This incident affected: Platform (Android, iOS).