APR 29- Investigating Store Issue
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Apr 30, 2020 - 16:39 UTC
Update
We are continuing to investigate. Daily Deals have been disabled for the day, sorry for the inconvenience!
Posted Apr 29, 2020 - 19:11 UTC
Investigating
We are currently experiencing an issue with the Magic: The Gathering Arena store and are investigating. Daily Deals are currently disabled. We will update you when we have more information.
Posted Apr 29, 2020 - 15:45 UTC
This incident affected: Store.