NOV 21 - Store Error

Incident Report for MTG Arena

Resolved

Our Store services have stabilized, so we are marking this issue as resolved. If you continue to experience any issues while playing MTG Arena, please contact support: https://mtgarena-support.wizards.com/hc/en-us
Posted Nov 22, 2019 - 01:00 UTC

Investigating

We are currently investigating reports of some players receiving Store Errors. We will update you with more information when it becomes available.
Posted Nov 21, 2019 - 23:04 UTC
This incident affected: Game and Store.