JUL 11 - Degraded Performance
Incident Report for MTG Arena
Resolved
Our services have stabilized, so we are marking this issue as resolved. For additional assistance, please Contact Support: https://mtgarena-support.wizards.com/hc/en-us/requests/new

Thank you for your patience, and we apologize for any inconvenience.
Posted about 1 month ago. Jul 12, 2019 - 00:14 UTC
Investigating
We are currently investigating reports of degraded performance on Magic: The Gathering Arena. Players may experience disconnects and/or other network related errors at this time.

If you experience any issues related to purchases or in-game rewards, please contact support for further assistance: https://mtgarena-support.wizards.com/hc/en-us/requests/new
Posted about 1 month ago. Jul 11, 2019 - 20:45 UTC
This incident affected: Game, Logins, Matches, and Store.