AUG 9 - JCB, American Express, and Discover Payment Options
Incident Report for MTG Arena
Resolved
Discover and American Express payment options should now be working correctly, so we are marking this incident as resolved. If players continue to experience issues with payment options, please reach out to Xsolla directly for additional support: https://help.xsolla.com/#contactUs

For all other issues, please contact MTG Arena's support team: https://mtgarena-support.wizards.com/hc/en-us
Posted 7 days ago. Aug 14, 2019 - 20:58 UTC
Identified
Update: Players should now be able to complete purchases using JCB. We are still working to address the issues with American Express and Discovery payment options.

Thank you for your patience, and we will update you with more information once it becomes available.
Posted 9 days ago. Aug 13, 2019 - 19:51 UTC
Investigating
Players attempting to make purchases using JCB, American Express, and/or Discover payment options may receive a "Selected payment currency is not supported." error message. We are aware of the issue, and are working on a fix.

We will update you with more information when it becomes available.
Posted 12 days ago. Aug 09, 2019 - 21:08 UTC
This incident affected: Store.