in-Game Store
Incident Report for MTG Arena
Resolved
We believe the issue has been resolved for our players, however we will continue to monitor the situation.
Posted 8 months ago. Nov 06, 2018 - 01:38 UTC
Investigating
We are currently investigating reports of some players experiencing issues with the in-game store. This includes but is not limited to general unresponsiveness or error messages when trying to complete a purchase.

We will update you with more information when it becomes available.
Posted 8 months ago. Nov 05, 2018 - 17:17 UTC
This incident affected: Store.