JUL 25 - Known Issue: Problem with Shortcut
Incident Report for MTG Arena
Resolved
This issue is now resolved. Players should expect a small update the next time Magic: The Gathering Arena is launched.

If you continue to experience issues, please contact support: https://mtgarena-support.wizards.com/hc/en-us
Posted 3 months ago. Jul 25, 2019 - 22:33 UTC
Identified
Players who are installing Magic: The Gathering Arena for the first time, or doing a clean install may see a "Problem with Shortcut" error message when launching the game from their desktop.

We are currently working on a fix. In the meantime, impacted users can launch from the Start Menu icon instead.
Posted 3 months ago. Jul 25, 2019 - 18:56 UTC
This incident affected: Game.