OCT 25 - Live Incident
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Oct 25, 2019 - 23:33 UTC
Update
This issue is now resolved. Please contact support (https://mtgarena-support.wizards.com/hc/en-us) if you encounter any further issues while playing.
Posted Oct 25, 2019 - 23:33 UTC
Monitoring
We have deployed a fix and are monitoring the situation. Please contact support (https://mtgarena-support.wizards.com/hc/en-us) if you continue to experience network related issues.
Posted Oct 25, 2019 - 22:24 UTC
Update
The issue is still under investigation. Players may receive network errors at this time. We will continue to update you with more information when it becomes available. Thank you for your patience!
Posted Oct 25, 2019 - 21:06 UTC
Update
The issue is still under investigation. Players may receive network errors at this time. We will continue to update you with more information when it becomes available.
Posted Oct 25, 2019 - 19:03 UTC
Investigating
We are currently investigating reports of an issue impacting Magic: The Gathering Arena. We will update you with more information when it becomes available.

We apologies for any inconvenience.
Posted Oct 25, 2019 - 17:31 UTC
This incident affected: Game.