Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 28, 2025 - 15:30 UTC
Scheduled
@MTG_Arena maintenance will occur to deploy the Avatar: The Last Airbender Preorder game update, containing bug fixes, updates, and the start of the MTG Arena Cube events.
- Powered Cube is now on Arena! Play now to earn powerful Cube Prize Packs.
- Magic: The Gathering | Avatar: The Last Airbender is available to preorder now! Claim the Momo Companion in the Play Bundle, Avatar Aang card in the Pack Bundle and the Sokka, Tenacious Tactician card in the Pass Bundle.
Posted Oct 27, 2025 - 18:08 UTC
This scheduled maintenance affected: Game, Logins, Matches, Social, and Store.