JUL 07- Investigating
Incident Report for
MTG Arena
Resolved
This incident has been resolved.
Posted
Jul
07
,
2020
-
21:36
UTC
Update
We are continuing to investigate this issue.
Posted
Jul
07
,
2020
-
20:30
UTC
Investigating
We are currently experiencing an issue with Magic: The Gathering Arena and are investigating. We will update you when we have more information.
Posted
Jul
07
,
2020
-
20:27
UTC
This incident affected: Game, Logins, Matches, and Store.
×
Subscribe to Incident
Subscribe to updates for
JUL 07- Investigating
via . You'll receive .