JUL 2 - Degraded Performance
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted 4 months ago. Jul 03, 2019 - 16:00 UTC
Monitoring
Our services have stabilized, and impacted players should now be able to update and connect to Magic: The Gathering Arena. Thank you once again for your patience, and we'll continue to monitor the situation.

If you experience any issues (including problems related to code redemption or purchases), please contact support: https://mtgarena-support.wizards.com/hc/en-us/requests/new
Posted 4 months ago. Jul 03, 2019 - 01:06 UTC
Update
This issue is still under investigation. We apologize for any inconvenience and will update you with more information as soon as it’s available.

Affected players should not manually modify game files to mitigate this issue, as it may have unexpected impact on your ability to experience Magic: The Gathering Arena.
Posted 4 months ago. Jul 02, 2019 - 22:07 UTC
Investigating
We are currently investigating reports of degraded performance impacting Magic: The Gathering Arena. Players may experience issues with updating to the latest client and/or logging in at this time.

We apologize for any inconvenience, and we will update you with more information when it becomes available.
Posted 4 months ago. Jul 02, 2019 - 16:55 UTC
This incident affected: Game, Logins, and Forums.