Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Nov 05, 2024 - 16:00 UTC
Scheduled
@MTG_Arena maintenance will occur to deploy the 2024.42.30 game update, containing important backend updates. This maintenance will require matchmaking and general game downtime. For More Details:
⏲️ ~3 hour estimated deployment. 🕗 8:00 AM PT: Matchmaking is disabled. 🕘 9:00 AM PT: Game downtime begins. (Approx. 30 minutes) 🪛 9:30 AM PT: MTG Arena is available. Scheduled maintenance continues. ✅11:00 AM PT: Estimated maintenance completion time.
There are no patch notes associated with this release.
Posted Nov 04, 2024 - 22:58 UTC
This scheduled maintenance affected: Platform (Windows, macOS, Android, iOS) and Game, Logins, Matches, Social, Store.