This issue should now be resolved. If you continue to experience any issues with downloading and/or updating Magic: The Gathering Arena, please contact support: https://mtgarena-support.wizards.com/hc/en-us
Posted Feb 14, 2019 - 19:45 UTC
Identified
We have identified the issue, and are working on a fix for the impacted players. At this time scheduled maintenance is considered complete, and are treating this as a separate live issue.
Posted Feb 14, 2019 - 18:09 UTC
Investigating
We're investigating reports of players having issues installing the latest update. Scheduled maintenance is still in progress.
Posted Feb 14, 2019 - 17:03 UTC
This incident affected: Game, Logins, Matches, and Store.