Arena Direct - Tarkir: Dragonstorm Store Links

Incident Report for MTG Arena

Resolved

This incident has been resolved.
Posted May 09, 2025 - 17:32 UTC

Investigating

We're aware of an issue with the Tarkir: Dragonstorm store links sent to Arena Direct participants. We're working to resolve this issue, and participants should expect additional info sent to their registered email soon.
Posted May 08, 2025 - 22:53 UTC
This incident affected: Platform (Windows, macOS, Android, iOS) and Store.