JUN 7 - Store Errors
Incident Report for MTG Arena
Resolved
This issue has been resolved. For further assistance, please contact support: https://mtgarena-support.wizards.com/hc/en-us Thank you for your patience.
Posted Jun 07, 2020 - 19:46 UTC
Identified
We're aware of an issue impacting monetary transactions (purchasing gems, pre-ordering Core Set 2021, etc.). Players may experience errors during checkout at this time. No other purchases are affected.

We apologize for the inconvenience, and will update you when the issue is resolved.
Posted Jun 07, 2020 - 18:51 UTC
This incident affected: Store.