NOV 21 - Network Error: Deck Validation
Incident Report for MTG Arena
Resolved
This issue should now be resolved. Patch notes are available, here: https://forums.mtgarena.com/forums/threads/61846
Posted Nov 26, 2019 - 19:18 UTC
Update
We are still working on fix, however there is no ETA at this time. If you are experiencing Deck Validation errors, swapping your Mirage basic lands to another set should function as a workaround. We apologize for the inconvenience.
Posted Nov 22, 2019 - 02:31 UTC
Identified
This appears to be impacting players who are currently using Mirage basic lands. We are currently working on a fix. In the meantime, if you experience this error we recommend changing your basic lands as a workaround.
Posted Nov 21, 2019 - 20:01 UTC
Investigating
We are currently investigating reports of deck validation errors when attempting to enter matches. We will update you with more information when it becomes available.
Posted Nov 21, 2019 - 19:10 UTC
This incident affected: Game and Matches.