AUG 2- PayPal
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted 3 months ago. Aug 02, 2019 - 22:42 UTC
Investigating
We are currently experiencing an issue with our PayPal Guest checkout. We will notify players when systems are fully operational again.
Posted 3 months ago. Aug 02, 2019 - 18:06 UTC
This incident affected: Store.