NOV 21 - Game Disruption

Incident Report for MTG Arena

Resolved

This incident has been resolved.
Posted Nov 21, 2021 - 16:43 UTC

Investigating

We are aware of an issue currently affecting Magic: The Gathering Arena. Players may not be able to access game features or login at this time. We will update you with more information when it becomes available.
Posted Nov 21, 2021 - 16:32 UTC
This incident affected: Platform (Windows, macOS, Android, iOS) and Game, Logins, Matches, Social, Store.