Connection Lost/Unable to Connect
Incident Report for MTG Arena
Resolved
We are seeing no further issues and the game services appear to be stable, so we are making this issue as resolved.
Posted 27 days ago. Nov 16, 2018 - 06:35 UTC
Monitoring
The issue appears to be resolved, however we are continuing to monitor the situation.
Posted 27 days ago. Nov 16, 2018 - 05:07 UTC
Investigating
We are currently investigating reports of players being unable to connect and/or losing connection to Magic: The Gathering Arena. We will update you with more information once it becomes available.
Posted 27 days ago. Nov 16, 2018 - 04:38 UTC
This incident affected: Game, Logins, Matches, and Store.