DEC 21 - Investigating
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Dec 22, 2021 - 19:37 UTC
Investigating
We are aware of an issue affecting the Decathlon 3: Traditional Draft and have disabled the event as we investigate.
Posted Dec 21, 2021 - 17:15 UTC
This incident affected: Platform (Windows, macOS, Android, iOS) and Game, Logins, Matches, Social, Store.