Traditional Draft and Sealed Events Disabled
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Aug 02, 2024 - 19:00 UTC
Identified
Due to an issues affecting sideboarding between matches, we have temporarily disabled Traditional (best-of-three) Draft and Sealed events. Players who are currently participating in these events will be able to resume their matches once the bug is fixed. We apologize for the inconvenience as we work to resolve this issue.
Posted Jul 30, 2024 - 22:01 UTC
This incident affected: Game.