Due to unforeseen circumstances, additional maintenance is required, tentatively scheduled for tomorrow, October 17, 2024. We will update you with more information once it becomes available.
Posted Oct 17, 2024 - 01:05 UTC
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Oct 17, 2024 - 00:02 UTC
Update
Maintenance is now scheduled to begin in 50 minutes (Oct 17, 2024, 00:00 UTC).
Posted Oct 16, 2024 - 23:10 UTC
Update
Maintenance has been delayed. We will update with more information when it becomes available, and apologize for any inconvenience.
Posted Oct 16, 2024 - 23:03 UTC
Scheduled
@MTG_Arena scheduled maintenance will occur to deploy the 2024.42.2 game update, containing a hotfix related to gameplay.
⏲️ Full deployment estimated at ~3 hours. 🛠️ No downtime is expected. 📝 Patch notes available soon after.
Posted Oct 16, 2024 - 21:31 UTC
This scheduled maintenance affected: Platform (Windows, macOS, Android, iOS) and Game, Logins, Matches, Social, Store.