APR 13- Maintenance to Workshop Event
Incident Report for MTG Arena
Resolved
This incident has been resolved. The Workshop Event queue is now operational.
Posted Apr 13, 2020 - 16:40 UTC
Investigating
We are investigating an issue in game. We have taken down the Workshop Event queue as a result, and will let you know when the queue is available again.
Posted Apr 13, 2020 - 15:48 UTC
This incident affected: Matches.