We have deployed a hotfix to address some of these issues. Patch notes are available, here: https://forums.mtgarena.com/forums/threads/66434 We are continuing to monitor the situation, and will provide additional updates as necessary.
Posted Jun 27, 2020 - 22:38 UTC
Identified
We have identified the cause of this issue, and we’re working towards releasing a hotfix as soon as possible. While there is no ETA at this time, we will update you with maintenance information as soon it’s available.
We apologize for any inconvenience and thank you for your patience and continued reports. For all other issues, please contact support: https://mtgarena-support.wizards.com/hc/en-us
Posted Jun 26, 2020 - 01:45 UTC
Investigating
We're investigating reports of players experiencing a "black screen" after the 1.09.00 Game Update for the release of Core Set 2021.