NOV 22 - Password Reset: Email Not Sent
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Dec 05, 2019 - 19:21 UTC
Update
For players who have not received their password reset email, you can manually request an email by going to: https://myaccounts.wizards.com/forgot and entering the email address associated with your MTG Arena account.

If you do not receive the email or you no longer have access to that email account, you will need to contact support for further assistance. https://mtgarena-support.wizards.com/hc/en-us/requests/new?ticket_form_id=360000022266
Posted Nov 23, 2019 - 00:02 UTC
Investigating
We are investigating as to why some players have not received an email to reset their password after following the password reset prompts. We believe this is an issue on the side of your email service provider, and will give more information when it is available.
Posted Nov 22, 2019 - 22:29 UTC
This incident affected: Logins.