SEP 10 - Quick Draft Unavailable
Incident Report for MTG Arena
Resolved
This issue has been resolved, and we have re-enabled the Adventures in the Forgotten Realms Quick Draft. If you were impacted by this outage, we are working on a mass reimbursement for all affected players; there is no need to contact customer service at this time.
Posted Sep 10, 2021 - 21:42 UTC
Investigating
We are currently investigating an issue related to Quick Drafts on MTG Arena, and have disabled the Adventures in the Forgotten Realms Quick Draft at this time. We apologize for any inconvenience, and will update you with more information when it is available.
Posted Sep 10, 2021 - 19:58 UTC
This incident affected: Game.