NOV 29 - Investigating
Incident Report for MTG Arena
Resolved
A fix has been developed and it will be released alongside our upcoming scheduled maintenance.
Posted Nov 30, 2021 - 20:23 UTC
Identified
The issue has been identified and we are working on a fix. Players who were affected will automatically receive reimbursement for their event entry. Expect these updates to occur within the next 24 hours.
Posted Nov 30, 2021 - 02:12 UTC
Investigating
We are aware of an issue affecting the Wedding Crashers and Jump In! events and are currently investigating. We will provide updates when necessary.
Posted Nov 29, 2021 - 22:25 UTC
This incident affected: Game and Matches.