MAY 7 - Login Errors
Incident Report for MTG Arena
Resolved
We are seeing no further issues, so we are marking this as resolved. For additional assistance, please contact support: https://mtgarena-support.wizards.com/ Thank you!
Posted May 08, 2020 - 00:38 UTC
Monitoring
This issue appears to be resolved, but we are continuing to monitor the situation. For additional assistance, please contact support: https://mtgarena-support.wizards.com/ We apologize for any inconvenience.
Posted May 07, 2020 - 21:28 UTC
Investigating
We are currently investigating reports of players receiving an error message when attempting to login. We will update you with more information when it becomes available.
Posted May 07, 2020 - 21:09 UTC
This incident affected: Game and Logins.