NOV 16 - Connection Issues
Incident Report for MTG Arena
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 02:00 UTC
Monitoring
Our systems appear to have stabilized, however we are continuing to monitor the situation. If you are still experiencing connectivity related issues, please contact support.
Posted Nov 16, 2020 - 22:24 UTC
Investigating
We are investigating reports of various connection issues, including prolonged instances of "waiting for server". We will update you with more information when it becomes available.
Posted Nov 16, 2020 - 19:28 UTC
This incident affected: Game, Logins, and Matches.